Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
Last revision Both sides next revision
os:macos [2023/01/27 11:18]
tomas
os:macos [2023/10/25 15:16]
tomas [Sit/network]
Line 1: Line 1:
-=====MacOS===== +===== MacOS ===== 
-== Sluzby==+==== Sluzby====
 launchctl list ... seznam slizem\\ launchctl list ... seznam slizem\\
 launchctl unload  /System/Library/LaunchDaemons/ssh.plist ... zastaveni/stop slushy\\ launchctl unload  /System/Library/LaunchDaemons/ssh.plist ... zastaveni/stop slushy\\
  
-== Balickovaci system ==+==== Balickovaci system ====
 brew install corkscrew       # ==> tunnel SSH through HTTP proxies brew install corkscrew       # ==> tunnel SSH through HTTP proxies
 brew install htop            # ==> https://htop.dev brew install htop            # ==> https://htop.dev
Line 10: Line 10:
 brew install tree            # ==> http://mama.indstate.edu/users/ice/tree brew install tree            # ==> http://mama.indstate.edu/users/ice/tree
 brew install vim             # ==> https://www.vim.orgtunnel SSH through HTTP proxies brew install vim             # ==> https://www.vim.orgtunnel SSH through HTTP proxies
 +brew install --cask balícek ... nejaké balíčky jsou typu cask - instalace balíčku\\
 +brew uninstall cask -balíček ... odinstalace cask balíčku\\
 +brew upgrade --cask --greedy --all ... upgrade a přeinstalování všech cask balíčků\\
 sudo installer -verbose -pkg aaa.pkg ... nainstaluje balíček\\ sudo installer -verbose -pkg aaa.pkg ... nainstaluje balíček\\
 pkgutil --pkgs ... seznam nainstalovaných balíčku\\ pkgutil --pkgs ... seznam nainstalovaných balíčku\\
Line 15: Line 18:
 pkgutil --only-files --files net.pulsesecure.TnccPlugin.pkg ... seznam nainstalovaných souboru z balíčku\\ pkgutil --only-files --files net.pulsesecure.TnccPlugin.pkg ... seznam nainstalovaných souboru z balíčku\\
  
-=== Sit/network ===+==== Sit/network ====
 [[https://github.com/xjasonlyu/tun2socks/wiki/Examples]] ... Socks5 nastavení\\ [[https://github.com/xjasonlyu/tun2socks/wiki/Examples]] ... Socks5 nastavení\\
 **stove karty**\\ **stove karty**\\
 ifconfig ... seznam síťových zařízení a ip adres\\ ifconfig ... seznam síťových zařízení a ip adres\\
 ifconfig lo0 10.0.0.1 alias ... pride dalsi alias (ip adresu)\\ ifconfig lo0 10.0.0.1 alias ... pride dalsi alias (ip adresu)\\
 +scutil --proxy ... ukáže nastavení proxy\\
  
 **Routing**\\ **Routing**\\
Line 48: Line 52:
 discoveryutil udnsflushcaches\\ discoveryutil udnsflushcaches\\
 dscacheutil -flushcache\\ dscacheutil -flushcache\\
 +
 +**Síťové profily**
 +networksetup -listlocations ... seznam profilů, tzv. lokací\\
 +networksetup -getcurrentlocation ... ukáže aktuálmí profil\\
 +networksetup -switchtolocation aaa ... přepne na profil aaa\\
  
 == Microsoft Defender == == Microsoft Defender ==
Line 54: Line 63:
 ==other== ==other==
 csrutil status ... system integrity protection status\\ csrutil status ... system integrity protection status\\
 +
 +==== správa zařízení a disků ====
 +system_profiler SPUSBDataType ... ukáže připojená USB zařízení\\
 +system_profiler SPPCIDataType ... sezam PCI zařízení\\
 +diskutil list ... seznam disků\\
 +diskutil listFilesystems ... seznam file systémů\\
 +ioreg -p IOUSB seznam USB\\